ネットワークラボ「Runa」の復活

ネットワークラボ「Runa」(RUtoru’s Network lAboratory)を復活させました。
3年ぶりです。
今のおうちに引っ越してから起動するのも初めて。
 
ほこり払って、計6台起動しましたが、すべて無事動きました。コンセントから煙が出たりすることもありませんでした。よかったよかった。
 
20080507_ラボ

 
パスワードを忘れていたので、6台のパスワードをすべて復旧させるのが大変でしたが(^^;;。
おかげでconfig registerの設定はスラスラ行えるようになりました(なりたくなかったが)。
 
さあいろいろ勉強していこう。

Continue reading “ネットワークラボ「Runa」の復活”

show running-configのフィルタリング

Ciscoルータ上で、設定を見ようとするとき、「sh run」コマンドを使用します。「terminal length 0」にしていなければ、「 –More–」で表示が止まります。
 
--------------------------------------------------
Router#sh run
Building configuration…
 
Current configuration : 399 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
–More–
--------------------------------------------------
 
というふうに。
 
ここで、フィルタリング表示ができます。
「/」を入力し、その後にキーワードを入れます。例えば、コンソールにパスワードが設定されているか確認するために、「con」が含まれている部分を表示したいとしましょう。
 
--------------------------------------------------
!(省略)
interface Serial0
no ip address
shutdown
/con
--------------------------------------------------
 
「 –More–」が「/con」に置き換えられます。
続いてリターンを押すと、
 
--------------------------------------------------
!
interface Serial0
no ip address
shutdown
/con
filtering…
line con 0
line aux 0
line vty 0 4
!
end
--------------------------------------------------
 
と「filtering…」表示と共にフィルタリングされて、「con」を含む部分以下が表示されます。
 
似たようなコマンドに、「sh run | include con」がありますが、
 
--------------------------------------------------
Router#sh run | include con
Building configuration…
Current configuration : 399 bytes
line con 0
Router#
--------------------------------------------------
 
というふうに、「con」を含む行しか表示されないので、不便です。
「/」入れてフィルタリングさせる方が便利です。
 
私はL3SWみたいに、ポートがたくさんある機器で良く使用します。「 –More–」が表示される度にスペースキーを押して探していくのは面倒なので。
 
Webにあまり情報がないので、解説してみました。

Continue reading “show running-configのフィルタリング”

clear line console 0

我がRunaラボで検証していたのですが、
 
ルータ(Runa-1)–< クロスLANケーブル>–ルータ(Runa-2)
 
という構成で、コンソール(Console)ケーブルをRuna-1に指し、TelnetでRuna-2にログインしていました。
 
しかーし、ついもののはずみでクロスケーブルを引っこ抜いてしまいました。
そうなると、Runa-1のコンソールのセッションが残ったままになるので、Runa-1にコンソールログインできなくなります。そういうときは、まずクロスケーブルを再度つなぎ、次にRuna-2からTelnetでRuna-1にログイン。そして特権モードで、
 
Runa-1# show sessions
 
とやると、コンソールセッションが残っていることがわかりますので、
 
Runa-1# clear line console 0
 
とやれば、コンソールセッションをクリアでき、Runa-1にコンソールログインできるようになります。
 
よかったよかった。
って、今日検証しようとしていたことはできずじまいになりましたが・・・

Continue reading “clear line console 0”

CiscoのEscape Sequence

たまに、
 

Runa-1#traceroute 192.168.2.2
 
Type escape sequence to abort.
Tracing the route to 192.168.2.2
 
1 * * *
2 * * *

 
と延々と続くことがあります。通信出来ないときにこうなります。
待つのも疲れるので、Escape Sequenceを送る必要があります。その場合は、
 
「Ctrl + Shift +6」
 
を行います。これで止まってすっきり。
 
一回で止まらない場合は容赦なく連打します。「Ctrl + Shift」は押したままにし、「6」を連打します。そうすると止まります。

Continue reading “CiscoのEscape Sequence”

ネットワークラボ「Runa」一応の完成

ネットワークラボ「Runa」(RUtoru’s Network lAbo)が一応完成しました。今、ルータ4台(Cisco 2500シリーズ)とスイッチ1台があります。
 
20050123202305.jpg

(一番下がラック、その上2台がルータ、その上1台がスイッチ、さらにその上にノートPCを置いています。残りのルータ2台は反対側に置いております)
 
置き場として、当初はテレビ台の流用を考えていたのですが、扉の開け閉めがめんどくさいので、止めました。
今はどこに設置しているかというと、テレビとかオーディオとかを置くのに使っているLuminousのスチールラックの上に設置しています。奥行きがちょうどルータの横幅とマッチし、きれいに備え付けることができました。
 
問題は耐震。
DIYショップで滑り止めシートを買ってきまして、ルータとルータの間に入れています。これで滑り落ちるようなことは無くなりました。しかしまだ弱いので、荷物用のベルトを買ってきて固定する予定。
 
これでいろいろと実験できます。
時間を見つけていろいろとやっていこうと思います。

Continue reading “ネットワークラボ「Runa」一応の完成”

Ciscoのデフォルト設定

Ciscoルータはshow runコマンドで設定を確認できるのですが、デフォルト設定は表示されないことがあります。例えば先ほどのコンソールへのログ出力ですが、デフォルトで有効です。しかしshow runすると、
 
Runa-1#show run
Building configuration…
 
Current configuration : 626 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Runa-1
!
enable secret(以下略)
 
と表示されます。
コンソールへのログをオフにすると、
 
Runa-1#show run
Building configuration…
 
Current configuration : 645 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Runa-1
!
no logging console
enable secret(以下略)
 
というふうに「no logging console」と表示されます。
 
これが、理解しているつもりでも時々私はポカってしまいます。コンフィグを見て「あー!設定が漏れている!」と焦ってしまうことが多々あります。デフォルト設定だから表示されていないだけなのに、です。注意しなければなりません。また、デフォルト設定には何の項目があって、初期に何の値が設定されるのかをしっかりと把握しておく必要があります。

Continue reading “Ciscoのデフォルト設定”

Ciscoのログ

Ciscoルータの設定をしていると、
 
Runa-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Runa-1(config)#
Runa-1(config)#exit
Runa-1#
00:36:52: %SYS-5-CONFIG_I: Configured from console by console
Runa-1#
 
というように、特権モード(Runa-1#)時にログが表示されます。これがうざい。早くshowコマンド等を打ちたいのに、邪魔であります。
これはログ出力先にコンソールが指定されているからです。邪魔であるばかりでなく、ルータ負荷の点からもよろしくありません。ログ出力先の負荷は、
 
コンソール > 外部Syslogサーバ > 仮想端末(VTY) > ロギングバッファ
 
という順番でありまして、コンソールが一番負荷をかけるのです。
(ここらへんはCCNPのCITの範囲ですね)
 
ログ出力先としてコンソールを指定するのを止めるのは、
 
Runa-1(config)#no logging console
 
とします。
ログを見るときはどうするかというと、
 
Runa-1#show logging
 
とすると、ロギングバッファ内のログを見ることができます。もちろん前提としてロギングバッファが有効になっていないといけません。ちなみに有効にするのは、
 
Runa-1(config)#logging buffered
 
です。

Continue reading “Ciscoのログ”

USB-Serial変換ケーブルとTeraTermPro

CiscoのルータやスイッチにPCを接続するには、ロールオーバーケーブルを使用します。ルータやスイッチに付属しているものの多くは、片方がRJ-45で、片方がシリアルです。RJ-45の方をルータやスイッチのConsoleポートに接続します。シリアルの方をPCにつなぎます。
 
最近の小型ノートパソコンにはシリアルインタフェースがありません。
そこで、USBとシリアルを変換してくれるケーブルを介して、接続しようとしました。変換ケーブルをUSBに差し込むと、ドライバが自動的にインストールされて、USB-シリアル変換を行ってくれるようになります。
 
この変換ケーブルを介してロールオーバーケーブルをつなぐと、ルータの設定ができるハズ。私はいつもTeraTermProというソフトを使っているので、このソフトで接続しようとしました。・・・が、接続できませんでした。何故かというと、変換ケーブルを使ったシリアルのポート(COMポート)が「6」になっているからなのです。TeraTermProは「4」までしか選択出来ないのです。
 
20050107142116.jpg

 
これには困りました。
色々調べたのですが、ちっともわからず・・・
ですが、先ほどやっとわかりました。TeraTermProは各種設定を「TERATERM.INI」というテキストファイルで行うのです。その中に、
 
; Max serial port number
MaxComPort=4
 
という部分がありまして、これを「6」にすればいいのです。
 
; Max serial port number
MaxComPort=6
 
設定後、TeraTermProを再起動すると、
 
20050107142122.jpg

 
というように、ちゃんとCOM6まで選択可能になりました。
これでルータにログイン可能となりました。よかったよかった。

Continue reading “USB-Serial変換ケーブルとTeraTermPro”

テレビ台がルータラック?

今、自宅にネットワークラボを構築しようとしています。
ルータやスイッチは意外に大きいので、どこに設置するかが問題になります。
 
部屋の掃除をしているときに、テレビ台を発見しました。
(何故か台所にテレビ台がありました・・・)
私のおうちはテレビをLuminousのラックに搭載しているので、テレビ台は必要ないのです。なので、昔使っていたテレビ台は部屋の隅に追いやられていました。
 
ふと思いつき、サイズを測ったところ、なんとルータやスイッチを収容するのにぴったりではありませんか!
テレビ台をきれいにし、その中にルータを入れたらすっぽりと収まりました。かなりいい感じです。ルータやスイッチを収容するために、自宅に安価な19インチラックを設置しようかなあと考えていたのですが、どうやらテレビ台でうまくいきそうです。低コストで済みました。
 
ラボが完成したら写真をアップしたいと思います。

Continue reading “テレビ台がルータラック?”

ルータを買う、その前に

ネットワークラボを構築するためには、ルータが必要です。
ルータを買うには色々な方法があります。あえて申しますまい。
 
ルータを購入する前に気を付けたいのは、
 
1.IOSバージョン
2.Feature Set

 
の2つ。
 
1.IOSバージョン
 
現時点(2004.12.28)での最新版はおそらく、
 
12.3メインライン
12.3Tトレイン
 
の2つ。Tトレインは新機能実装版です。これらのバージョンに近ければ近いほど新しいことになります。バージョンにカッコが付いていたり、いろいろありますが、細かいところは専門書を参考にしてください。
(なお、Catalyst IOSは最新が12.3とは限らないのでご注意を。Catalyst IOSは選択が難しいので、本文対象外とします)
 
少なくとも12.x以降が欲しいところです。購入前に必ずチェックするようにしましょう。
 
2.Feature Set
 
Runa-1#show version
 
上記を入力すると、例えば以下のように表示されます。
 
Cisco Internetwork Operating System Software
IOS ™ 2500 Software (C2500-JS-L), Version 12.2
(以下略。私の保有するルータの出力例です)
 
この中の「C2500-JS-L」がIOSイメージのIDでありまして、これに注目であります。
JSがFeature Setにあたります。
 
J=「Enterprise」
S=「Plus」
 
ですので、このルータのFeature Setは「Enterprise Plus」ということになります。
(詳しくはこちらを参照のこと)
 
Enterpriseが入っていると、色々とできますのでいいかと思います(他と比べると高いですが ※)。例えば、
 
Runa-1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Runa-1(config)#router isis
Runa-1(config-router)#net ?
XX.XXXX. … .XXX.XX Network entity title (NET)
 
みたいな感じで、IS-ISも使用できますし。
 

※ EnterpriseとIP Plusとの違いとかは私にもまだよくわかっておりません(調べたのですが、いい情報ソースがありませんでした)。

Continue reading “ルータを買う、その前に”